Issue with creating beneficiaries
Incident Report for Modulr Finance Limited
Resolved
This incident has been resolved.
Posted Feb 07, 2022 - 18:23 GMT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 07, 2022 - 18:22 GMT
Identified
We are aware of a current problem in our service which is preventing users from approving/retrieving beneficiaries on the platform, which in turn is is preventing users from making payments.

We have identified the issue and are currently in the process of putting a fix in place.

Please note that this had no effect on any inbound payments.

Please accept our apologies for any inconvenience caused and please be assured we are working to resolve this as quickly as possible. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Feb 07, 2022 - 18:03 GMT
This incident affected: Faster Payment Service and Modulr Customer Portal.