Cloudflare Service Disruption (Payment Processing Delays & Website Access Issues)

Incident Report for Modulr Finance Limited

Resolved

We have taken remediation action and can confirm that both SEPA and FPS payment services and portal access are operational.

Please accept our apologies for any inconvenience caused.

If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com. Thank you for your patience and understanding.
Posted Nov 18, 2025 - 19:19 GMT

Update

We are still working on carrying out the remediation steps, however, most of the payments should now be reflecting correctly. No new payments should be affected by the incident.

We will keep you up-to-date via this page once the remediation has been fully carried out.

Thank you for your continued patience and again, please accept our apologies for any inconvenience caused!

If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Nov 18, 2025 - 17:58 GMT

Monitoring

Cloudflare has notified us that they have implemented a fix and that the incident should now be resolved.

We are currently remediating the affected payments and will give an update here once the remediation steps have been carried out.

Portal login for Sage and BrightPay users should now work as expected.

Thank you for your continued patience and again, please accept our apologies for any inconvenience caused!

If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Nov 18, 2025 - 15:51 GMT

Update

We are currently experiencing a service disruption impacting inbound and outbound SEPA Instant and SEPA Credit payment processing, as well as access to our portal. We have also identified a number of inbound and outbound FPS payments impacted.

The issue stems from an external problem with one of our third-party providers, Cloudflare, which is currently facing a service outage.

Our team is actively monitoring the situation and will share further updates as soon as they become available.
Payments affected by this incident will remain in a pending status until the issue is resolved.
Portal access should only be impacted for Sage and BrightPay customers.

Please accept our apologies for any inconvenience caused and please be assured we are working to resolve this as quickly as possible. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Nov 18, 2025 - 14:47 GMT

Investigating

We are currently experiencing a service disruption impacting inbound and outbound SEPA Instant and SEPA Credit payment processing, as well as access to our portal.

The issue stems from an external problem with one of our third-party providers, Cloudflare, which is currently facing a service outage.
Our team is actively monitoring the situation and will share further updates as soon as they become available.

Payments affected by this incident will remain in a pending status until the issue is resolved.
Portal access should only be impacted for Sage and BrightPay customers.

Please accept our apologies for any inconvenience caused and please be assured we are working to resolve this as quickly as possible. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Nov 18, 2025 - 13:24 GMT
This incident affected: Faster Payment Service, SEPA (Euro) Payment Service, and Modulr Customer Portal.