Inbound an Outbound Transactions Being Held
Incident Report for Modulr Finance Limited
Resolved
Thank you for your patience.

I can confirm that this incident has now been resolved and all payments are processing normally.

If you have any questions please don't hesitate to contact support on support@modulrfinance.com or 03033130060
Posted Jun 19, 2020 - 15:03 BST
Monitoring
Thank you for your patience.

Payments are now processing as normal as we continue to work on the platform.

All failed payments are now safe to retry.

If you have any questions please don't hesitate to contact support on support@modulrfinance.com or 03033130060.
Posted Jun 19, 2020 - 14:02 BST
Investigating
We are currently experiencing an issue with our platform and we have held both our outbound and inbound payment queue whilst we repair the platform.

All payments will be held and the released once the incident is resolved.

Please be assured we are working to resolve this as quickly as possible and we will keep you updated regularly until this matter is resolved.

We apologize for any inconvenience this may be causing and thank you for your continued patience whilst we work to resolve this.

If you have any questions please don't hesitate to contact support on support@modulrfinance.com or 03033130060
Posted Jun 19, 2020 - 13:41 BST
This incident affected: Faster Payment Service.