SEPA Payment Outage
Incident Report for Modulr Finance Limited
Resolved
We can confirm our SEPA Service is now functional again and both Inbound and Outbound SEPA instant payments are being processed successfully.

Any Inbound SEPA payments that have failed can now be reattempted. Any outbound SEPA Instant payments that are pending still will be processed accordingly.

Please accept our apologies for any inconvenience caused. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Jun 21, 2023 - 10:22 BST
Investigating
We are currently investigating an issue with SEPA outbound and inbound payments. This is due to an outage with our gateway provider.

SEPA payments will be currently failing until our service resumes again. Any inbound payments will also show as a failure from the sending bank.

Please be assured we are investigating and working with them to resolve this matter as quickly as possible.

Please accept our apologies for any inconvenience caused and please be assured we are working to resolve this as quickly as possible. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Jun 21, 2023 - 10:09 BST
This incident affected: SEPA (Euro) Payment Service.