Our SEPA service continues to operate normally since our previous update. We have completed our actions and now can confirm that all affected payments have been released and accounts have been unblocked.
If you require further assistance regarding this issue, please do not hesitate to contact us at: support@modulrfinance.com.
Posted Aug 05, 2025 - 23:31 BST
Update
Our SEPA service continues to operate normally since our previous update. We are finalising the actions to remediate any held payments and accounts that were blocked. This should be completed shortly, and we will provide an update to confirm once the activity is complete.
Our team is also working diligently to review any payments that may have been impacted. If you require further assistance regarding this issue, please do not hesitate to contact us at: support@modulrfinance.com.
Posted Aug 05, 2025 - 21:33 BST
Update
Thank you for your patience. We are pleased to confirm that we have not experienced any further recurrences of the issue that occurred earlier this afternoon.
We are finalising the actions to remediate any held payments and accounts that were blocked. This should be completed shortly, and we will provide an update to confirm once the activity is complete.
Our team is also working diligently to review any payments that may have been impacted. If you require further assistance regarding this issue, please do not hesitate to contact us at: support@modulrfinance.com.
Posted Aug 05, 2025 - 17:34 BST
Monitoring
Thank you for your patience. We have been working closely with our provider, and a fix has now been implemented. The system is currently under active monitoring to ensure continued stability.
Our team is also working diligently to review any payments that may have been impacted. If you require further assistance regarding this issue, please do not hesitate to contact us at: support@modulrfinance.com.
We will continue to keep you updated.
Posted Aug 05, 2025 - 16:10 BST
Investigating
We have identified and are currently investigating an issue with our provider which is affecting both outbound and inbound SEPA payments, which may result in delays. In some cases, this may also lead to temporary account restrictions.
SEPA Instant payments are expected to be processed as SEPA Instants, we do not expect these to be converted to SEPA Credit Transfers at this time.
Please be assured that we are investigating and working to resolve this as a priority issue.
We appreciate your patience and understanding as we work to resolve this matter as swiftly as possible. Should you require further assistance, please do not hesitate to contact our support team at support@modulrfinance.com.
Posted Aug 05, 2025 - 15:07 BST
This incident affected: SEPA (Euro) Payment Service.