Customer Portal Unavailable
Incident Report for Modulr Finance Limited
Resolved
We are pleased to confirm that following a period close monitoring we are confident our portal is now working normally. You will be able to log in and use all the functionality as you normally would.

We have identified that the cause of this incident was related to technical difficulties Amazon Web Services (AWS) were experiencing, which directly impacted our provider of the Authy app that our portal users use to log in with.

Please accept our apologies for the any inconvenience caused by this incident, and we thank you for your patience whilst this issue was resolved.
Posted Nov 26, 2020 - 09:22 GMT
Monitoring
We are now seeing success with Authy Two Factor Authentication for login. We are aware that there is still some slowness issues for login and logout and advise that if you experience an issue logging in to please retry.

Our Authy app provider is still working to resolve the issue, we will be in touch to provide further update as soon as possible.

If you have persistent login issues and payments that need to be made urgently please contact our support team who will be happy to assist: support@modulrfinance.com

Please accept our apologies for any inconvenience this incident is causing. We thank you for your continued patience.
Posted Nov 26, 2020 - 06:41 GMT
Update
We are now seeing success with Authy Two Factor Authentication for login. We are aware that there is still some slowness issues for login and logout and advise that if you experience an issue logging in to please retry.

Our Authy app provider is still working to resolve the issue and will continue to do so through the night and we will be in touch to provide an update as soon as possible.

If you have persistent login issues and payments that need to be made urgently please contact our support team who will be happy to assist: support@modulrfinance.com

Please accept our apologies for any inconvenience this incident is causing. We thank you for your continued patience.
Posted Nov 25, 2020 - 21:43 GMT
Update
We are now seeing success with Authy Two Factor Authentication for login. We are aware that there is still some slowness issues for login and logout and advise that if you experience an issue logging in to please retry.

Our Authy app provider is still working to resolve the issue.

If you have persistent login issues and payments that need to be made urgently please contact our support team who will be happy to assist: support@modulrfinance.com

Please accept our apologies for any inconvenience this incident is causing. We will continue to keep you updated as our provider works to resolve this.
Posted Nov 25, 2020 - 20:40 GMT
Update
Our authy app provider is still working to resolve the issue that is stopping users from being able to log in or approve successfully.

If you have any payments that need to be made urgently please contact our support team who will be happy to assist: support@modulrfinance.com

Please accept our apologies for any inconvenience this incident is causing. We will continue to keep you updated as our provider works to resolve this.
Posted Nov 25, 2020 - 19:23 GMT
Update
Our authy app provider is still working to resolve the issue that is stopping users from being able to log in or approve successfully.

If you have any payments that need to be made urgently please contact our support team who will be happy to assist: support@modulrfinance.com

Please accept our apologies for any inconvenience this incident is causing. We will continue to keep you updated as our provider works to resolve this.
Posted Nov 25, 2020 - 18:08 GMT
Update
Our authy app provider is still working to resolve the issue that is stopping users from being able to log in or approve successfully.

If you have any payments that need to be made urgently please contact our support team who will be happy to assist: support@modulrfinance.com

Please accept our apologies for any inconvenience this incident is causing. We will continue to keep you updated as our provider works to resolve this.
Posted Nov 25, 2020 - 16:59 GMT
Update
Our provider of the authy app is working to resolve this issue as quickly as possible and we will continue to keep you updated until this matter is resolved. We will be in touch with an update in an hour, or as soon as an update is available.
Posted Nov 25, 2020 - 16:14 GMT
Identified
We have identified the cause relates to degraded performance our provider of the authy app are experiencing . We are in close contact with them as they work to resolve this issue and we will continue to keep you updated until this issue has been fully resolved.
Posted Nov 25, 2020 - 15:24 GMT
Investigating
We are aware of an issue with our authentication app authy which is causing notifications to be delayed by several minutes, which is stopping users from logging in to our portal or approving payments/beneficiaries.

We apologize for any inconvenience this may be causing and we will keep you regularly updated as we work to resolve this issue.
Posted Nov 25, 2020 - 15:11 GMT
This incident affected: Modulr Customer Portal.