Payment Initiation Service - Outage
Incident Report for Modulr Finance Limited
Resolved
I can confirm this issue is now resolved. We are not seeing any further errors relating to this Payment Initiation Outage and we have observed successful requests.

Please accept our apologies for any inconvenience caused by this intermittent outage. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted May 23, 2024 - 21:36 BST
Monitoring
A fix has been implemented and we are currently monitoring our Payment Initiation Service. Customers should now should be able to complete payment initiation requests successfully.

Please accept our apologies for any inconvenience caused. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted May 23, 2024 - 21:28 BST
Identified
The issue has been identified and we are working on actions to remediate this.

Please accept our apologies for any inconvenience caused. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted May 23, 2024 - 21:04 BST
Investigating
We are currently aware of an ongoing outage with our Payment Initiation Service (PIS). Customers currently may not be able to complete payment initiation requests from external banks to the Modulr Platform.

Please be assured we are investigating and working to fix this issue.

Please accept our apologies for any inconvenience caused. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted May 23, 2024 - 20:32 BST
This incident affected: Payment Initiation Service (PIS).