Inbound BACS payments have not credited
Incident Report for Modulr Finance Limited
Resolved
I am pleased to confirm that all delayed BACS inbound payments have now been processed.

Please be assured we have identified the cause of this delay and it is being addressed to ensure there are no related delays in the future.

Thank you for your patience whilst we worked to resolve this issue and please do accept our apologies for any inconvenience caused.
Posted Dec 18, 2020 - 13:23 GMT
Update
We have improved the processing performance of the BACS inbound payments and now expect all payments to be processed by 1:30PM.

So far we have processed 63% of today's inbound BACS payments.

We will continue to keep you updated on the progress as we process these BACS payments, and apologize for any inconvenience this is causing.
Posted Dec 18, 2020 - 12:38 GMT
Update
The estimated BACS inbound completion time remains at 2:15PM, however we continue to investigate possible avenues to speed the process up.

So far we have processed 43% of today's inbound BACS payments.

We will continue to keep you updated on the progress as we process these BACS payments, and apologize for any inconvenience this is causing.
Posted Dec 18, 2020 - 11:36 GMT
Update
We have observed a further delay to the processing of the inbound BACS payments which means we expect all inbound BACS payments to be processed by 2:15PM.

So far we have processed 26% of today's inbound BACS payments.

We will continue to keep you updated on the progress as we process these BACS payments, and apologize for any inconvenience this is causing.
Posted Dec 18, 2020 - 10:39 GMT
Update
The processing of the inbound BACS payments is taking longer than we anticipated, and for this reason now expect all payments will be credited by 10.40AM. We continue to closely monitor the processing of these payments and will provide further updates if there is any change to the expected completion time.
Posted Dec 18, 2020 - 09:41 GMT
Monitoring
The inbound BACS payments that were not applied earlier this morning are now processing. We expect all payments to be credited by 10.15AM, please note you will see payments being applied from now until the process completes.

We will be in touch to confirm when all BACS payments have been applied, which we expect to be by 10.15AM.
Posted Dec 18, 2020 - 09:19 GMT
Update
We have identified a faster alternative solution to the code change mentioned in our last update. We are proceeding with this new fix which will allow us to successfully process the inbound BACS payments, we expect all payments to be successfully processed by 10.15AM. Please be assured we are working to deliver this as quickly as possible and will keep you updated.

If we can be of any further assistance please do let us know: support@modulrfinance.com
Posted Dec 18, 2020 - 08:41 GMT
Identified
We have identified the cause of the issue and will be making a small code change to allow us to rerun the BACS file that has failed to credit. We don't have a definitive time-frame for these actions to be completed, however we are working to deliver this as early as possible this morning.

We will continue to keep you regularly updated as we work to resolve this issue.
Posted Dec 18, 2020 - 07:55 GMT
Investigating
All inbound BACS payments due for payment today have not yet been credited. Normally these payments are credited in the early hours of the morning. We are investigating the issue urgently and will keep you updated as we work to apply these payments.

Please accept our apologies for any inconvenience caused and if you require any further support in relation to this issue please do not hesitate to contact us: support@modulrfinance.com
Posted Dec 18, 2020 - 07:23 GMT
This incident affected: BACS Inbound Service.