Direct Debit Collection Delay
Incident Report for Modulr Finance Limited
Resolved
We can confirm this issue has now been resolved and we have successfully processed the collection run at 1pm. All future collections will continue to be collected at the normal scheduled time.

Please accept our apologies for any inconvenience caused.

If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Jun 13, 2022 - 13:06 BST
Monitoring
We have successfully loaded the direct debit collections on to our platform due for collection today.

We will attempt to complete the collection run at 1pm. All collections after this will be processed as per the normal scheduled time.

A further update will be provided after 1pm.

Please accept our apologies for any inconvenience caused and please be assured we are working to resolve this as quickly as possible. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Jun 13, 2022 - 11:29 BST
Identified
We have identified the root cause of the delay and we are currently implementing a fix for this issue.

We anticipate this will be complete within the next hour. A further update will be provided at 12pm.

Please accept our apologies for any inconvenience caused and please be assured we are working to resolve this as quickly as possible. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Jun 13, 2022 - 10:55 BST
Investigating
We are currently investigating an issue with Direct Debit collections due to be debited today from our customer accounts. Collections have not taken place.

We are looking into this with urgency and will provide an update with further details as soon as we have identified this issue.

Please accept our apologies for any inconvenience caused and please be assured we are working to resolve this as quickly as possible. If you require any further support in relation to this issue, please do not hesitate to contact us: support@modulrfinance.com
Posted Jun 13, 2022 - 10:03 BST
This incident affected: Direct Debit Payment Service.