Outbound payments held
Incident Report for Modulr Finance Limited
Resolved
This incident has now been resolved.

We have had confirmation from our Banking Partner and technical operations team that all outbound and inbound payments are now processing successfully. Any pending payments as a result of this incident are now being processed.

Please check any payments that were due to go out in the last 6 hours, If you have any queries or require assistance then please contact us.

We apologize for any inconvenience this has caused.
Posted Feb 15, 2020 - 08:01 GMT
Update
We are continuing to investigate this issue.

Our Technical team are working with our Banking Partner to identify the issue.

Once we have identified the issue we will contact you to update the situation.

We apologize for this inconvenience and hope to have this situation resolved soon.

Thank you for your continued patience with this.
Posted Feb 15, 2020 - 07:06 GMT
Update
We are continuing to investigate this issue.
Posted Feb 15, 2020 - 07:06 GMT
Investigating
We have investigated that there are some payments submitted between 2am & 3am that have not yet processed and are working with our banking partner to understand payment resolution as quickly as we can
We are very sorry for any inconvenience this has caused
Posted Feb 15, 2020 - 06:53 GMT
This incident affected: Faster Payment Service.