Unable to log into the customer portal
Incident Report for Modulr Finance Limited
Resolved
I am pleased to say the issue preventing users from logging into the customer portal has been resolved.

Apologies for any inconvenience this may have caused and thank you for your patience as we worked to resolve this issue.
Posted Jul 16, 2020 - 16:24 BST
Investigating
We are aware that users are currently unable to log into the customer portal. We are working closely to resolve this with our infrastructure partner as a matter of urgency.

Apologies for any inconvenience this is causing. We will keep you updated as we work to resolve this and thank you for your patience in the meantime.
Posted Jul 16, 2020 - 15:55 BST
This incident affected: Modulr Customer Portal.